how to configure switch-configure-timeout #help #opendaylight


Hojin Lee
 

Thank you for the reply.
I rewrote this message. because i'm not sure previous my message is sent to you.
 
anyway, i know that is expected way. but what i want to do is to change that. 
as i know, it is related with <switch idle timeout> tag which is default value 15sec . 
and if i change to 0, then it keeps all the connection regardless of packet exchange 
 
in my application, they get the network metrics from the controller and then it stops the simulator. 
after that it gave these metrics to the matlab and calculate it. and when it completes calculation they resume the simulator.
they do this repeatedly. 
 
but problem is, because calculation is time consuming(in this time there is no packet exchange) odl disconnect all the connections.
eventually, i want to keep this connection forever.  
 
i wonder whether you understand my intention. because i have poor english.
i hope you understand my situation and know resolution.
 
Thank you,


Luis Gomez
 

OpenFlow topology only shows when switches are connected to the controller, that is expected behavior is this is what your question is about.

BR/Luis


On Sep 12, 2021, at 8:17 PM, hj2913 via lists.opendaylight.org <hj2913=ajou.ac.kr@...> wrote:

hi, i'm one of the student using opendaylight controller.

i'm doing some project. and simulation stop and resume often.
but when the simulation stops, i can't see the topology on web-page(dlux topology) and can't get topology information using REST API.

in my opinion, this is because when i stop the simulation there is no packet exchange so controller disconnect connection.

so i tried to change switch-idle-timeout option in xml files. default 15seconds to 0( permanent). but it doesn't work.

these are what i have done. can anybody help me ? 

1.modify value of the <switch-idle-timeout> tag in files

i explore the folder and changed the value of the <switch-idle-timeout> tag.
these are file list and example code.
{folder}/etc/opendaylight/karaf/42-openflowplugin-Li.xml
{folder}/system/org/opendaylight/openflowplugin/openflowplugin-controller-config-Li/HE.xml

<dummyfile.0.part>

2. added <switch-idle-timeout> tag in the files

solution 1 doesn't seem to work. so i added <switch-idle-timeout> tag and value into the file which is related with switch-connection.
these are file list and example code.
{folder}/etc/opendaylight/datastor/initial/defalut-openflow-connection-config.xml
{folder}/etc/opendaylight/datastor/initial/legacy-openflow-connection-config.xml
{folder}/system/org/opendaylight/openflowjava-openflowjava-blueprint-config/0.9.4-Carbon/openflowjava-blueprint-config-0.9.4-Carbon-config.xml
{folder}/system/org/opendaylight/openflowjava-openflowjava-blueprint-config/0.9.4-Carbon/openflowjava-blueprint-config-0.9.4-Carbon-legacyconfig.xml

<dummyfile.1.part>

but i think these things doesn't affect to the connection. 
is there anyone who can help me ? 





Hojin Lee
 

hi, i'm one of the student using opendaylight controller.

i'm doing some project. and simulation stop and resume often.
but when the simulation stops, i can't see the topology on web-page(dlux topology) and can't get topology information using REST API.

in my opinion, this is because when i stop the simulation there is no packet exchange so controller disconnect connection.

so i tried to change switch-idle-timeout option in xml files. default 15seconds to 0( permanent). but it doesn't work.

these are what i have done. can anybody help me ? 

1.modify value of the <switch-idle-timeout> tag in files

i explore the folder and changed the value of the <switch-idle-timeout> tag.
these are file list and example code.
{folder}/etc/opendaylight/karaf/42-openflowplugin-Li.xml
{folder}/system/org/opendaylight/openflowplugin/openflowplugin-controller-config-Li/HE.xml



2. added <switch-idle-timeout> tag in the files

solution 1 doesn't seem to work. so i added <switch-idle-timeout> tag and value into the file which is related with switch-connection.
these are file list and example code.
{folder}/etc/opendaylight/datastor/initial/defalut-openflow-connection-config.xml
{folder}/etc/opendaylight/datastor/initial/legacy-openflow-connection-config.xml
{folder}/system/org/opendaylight/openflowjava-openflowjava-blueprint-config/0.9.4-Carbon/openflowjava-blueprint-config-0.9.4-Carbon-config.xml
{folder}/system/org/opendaylight/openflowjava-openflowjava-blueprint-config/0.9.4-Carbon/openflowjava-blueprint-config-0.9.4-Carbon-legacyconfig.xml



but i think these things doesn't affect to the connection. 
is there anyone who can help me ?