Re: Quagga needs to be updated with latest packages.


Srinivas <srinivas.rachakonda@...>
 

Hi Anil,

 

I have started working on the dcgw issues. (With all other python3/infra issues being resolved now).

 

Can you please point me the latest quagga images (CentOS).

 

I am planning to change the quagga images in the below dcgw script to point to the latest image.

 

https://github.com/opendaylight/integration-test/blob/master/csit/scripts/dcgw-setup.sh

 

I need packages to be at the URL:

 

Nexus_url="https://nexus.opendaylight.org/content/repositories/thirdparty/quagga[X]"

e.g.

Nexus_url=https://nexus.opendaylight.org/content/repositories/thirdparty/quagga4

 

Thanks,

Srinivas

+91-9243478719

 

From: Anil Belur <abelur@...>
Sent: 27 May 2020 14:58
To: srinivas.rachakonda@...
Cc: Jamo Luhrsen <jluhrsen@...>; integration-dev@...; odl netvirt dev <netvirt-dev@...>; Manjunatha H M <manjunathahm@...>; Karthikeyan Krishnan <karthikeyan.k@...>; Dayavanti Gopal Kamath <dayavanti.gopal.kamath@...>; Sivakumar Perumalla <sivakumar.perumalla@...>
Subject: Re: [integration-dev] Quagga needs to be updated with latest packages.

 

 

 

On Thu, May 21, 2020 at 9:15 PM <srinivas.rachakonda@...> wrote:

Thanks Anil.

 

 

The CentOS7 packages are built successfully, you can find the packages in the logs.

 

 

We still have issues that need to be addressed for building the quagga binaries on Ubuntu 16.04 and 18.04:

 

1. With Ubuntu 16.04 we are seeing errors with the following. Installing Python 3.6 on Ubuntu 16.04 is non-trivial, while the version of heatclient being installed requires python 3.5.2. Since we are close to EOL for Ubuntu 16.04 would it be possible to move to Ubuntu 18.04 for getting these dependencies built? 

 

22:59:55 ---> python-tools-install.sh
22:59:55 Generating Requirements File
22:59:55 WARNING: Python projects should move to Ubuntu 18.04 to continue receiving support
23:00:01 /home/jenkins/.local/lib/python3.5/site-packages/pip/_vendor/requests/__init__.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.
23:00:01   warnings.warn(warning, RequestsDependencyWarning)
23:00:03 /home/jenkins/.local/lib/python3.5/site-packages/pip/_vendor/requests/__init__.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.
23:00:03   warnings.warn(warning, RequestsDependencyWarning)
23:00:03 ERROR: Package 'python-heatclient' requires a different Python: 3.5.2 not in '>=3.6'

 

 

While building Quagga binaries on Ubuntu 18.04, I still see the following error looks like its an easy fix, that needs to be addressed in Quagga build script in downstream zrpcd repo.

 

03:29:28 ++ chmod a+x /tmp/packager/zrpc/deb/bin/DEBIAN/prerm
03:29:28 ++ printf '#!/bin/sh\n'
03:29:28 ++ printf 'set -e\n'
03:29:28 ++ printf 'if [ "$1" = "remove" ]; then\n'
03:29:28 ++ printf '  :\n'
03:29:28 ++ printf 'fi\n'
03:29:28 ++ chmod a+x /tmp/packager/zrpc/deb/bin/DEBIAN/postrm
03:29:28 +++ dirname ./packaging.sh
03:29:28 ++ PKG_DIR=.
03:29:28 ++ fakeroot dpkg-deb -b /tmp/packager/zrpc/deb/bin .
03:29:28 dpkg-deb: warning: parsing file '/tmp/packager/zrpc/deb/bin/DEBIAN/control' near line 7 package 'zrpc':
03:29:28  missing architecture 

03:29:28 dpkg-deb: error: package architecture is missing or empty

 

 

Thanks,

Anil

Join integration-dev@lists.opendaylight.org to automatically receive all group messages.