Netvirt CSIT job failures.


Srinivas <srinivas.rachakonda@...>
 

Hi Jamo,

 

Logs:

 

https://logs.opendaylight.org/sandbox/vex-yul-odl-jenkins-2/srini-netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-rocky-dcgw-silicon/3/control_1/stack.log.gz

 

 

Job:

https://jenkins.opendaylight.org/sandbox/job/srini-netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-rocky-dcgw-silicon/

 

 

After trying multiple fixes for Devstack installation as part for Netvirt CSIT jobs, I am stuck in the below error:

 

+ inc/python:_setup_package_with_constraints_edit:540 :   /opt/stack/requirements/.venv/bin/edit-constraints /opt/stack/requirements/upper-constraints.txt -- keystone '-e file:///opt/stack/keystone#egg=keystone'

Traceback (most recent call last):

  File "/opt/stack/requirements/.venv/bin/edit-constraints", line 8, in <module>

    sys.exit(main())

  File "/opt/stack/requirements/.venv/lib/python2.7/site-packages/openstack_requirements/cmds/edit_constraint.py", line 69, in main

    reqs = requirement.parse(content, permit_urls=True)

  File "/opt/stack/requirements/.venv/lib/python2.7/site-packages/openstack_requirements/requirement.py", line 88, in parse

    return to_dict(to_reqs(content, permit_urls=permit_urls))

  File "/opt/stack/requirements/.venv/lib/python2.7/site-packages/openstack_requirements/requirement.py", line 174, in to_dict

    for req, req_line in req_sequence:

  File "/opt/stack/requirements/.venv/lib/python2.7/site-packages/openstack_requirements/requirement.py", line 198, in to_reqs

    yield parse_line(req_line, permit_urls=permit_urls), content_line

  File "/opt/stack/requirements/.venv/lib/python2.7/site-packages/openstack_requirements/requirement.py", line 152, in parse_line

    parsed = pkg_resources.Requirement.parse(req_line)

  File "/opt/stack/requirements/.venv/lib/python2.7/site-packages/pkg_resources.py", line 2700, in parse

    reqs = list(parse_requirements(s))

  File "/opt/stack/requirements/.venv/lib/python2.7/site-packages/pkg_resources.py", line 2638, in parse_requirements

    line, p, specs = scan_list(VERSION,LINE_END,line,p,(1,2),"version spec")

  File "/opt/stack/requirements/.venv/lib/python2.7/site-packages/pkg_resources.py", line 2606, in scan_list

    raise ValueError("Expected "+item_name+" in",line,"at",line[p:])

ValueError: ('Expected version spec in', 'ceilometer===11.1.0', 'at', '===11.1.0')

 

 

 

I tried correcting it, but it still failed with the above error:

 

function fix_broken_requirements_versions() {

    local ip=$1

    ${SSH} "${ip}" "

        cd /opt/stack;

        git clone https://git.openstack.org/openstack/requirements;

        cd requirements;

        git checkout ${ODL_ML2_BRANCH};

        sed -i s/libvirt-python===3.10.0/libvirt-python===4.10.0/ upper-constraints.txt

        sed -i '1 auwsgi===2.0.18' upper-constraints.txt

        sed -i '1 asetuptools===1.4' upper-constraints.txt

        sed -i '1 aceilometer===11.1.0' upper-constraints.txt

        "

}

 

Can you please suggest what am I missing.

 

 

 

Thanks,

Srinivas

+91-9243478719

 

Join integration-dev@lists.opendaylight.org to automatically receive all group messages.