Re: [controller-dev] Netconf plugin testing

Reinaldo Penno <rapenno@...>

I will test again later today and get back to you.

In the meantime, can you test something simple? Change header to <Accept: application/xml> and perform GET again.  I seem to remember an issue around that.

The error below seem network related. I will retest anyway.

On Tue, Apr 1, 2014 at 3:59 PM, Madhusudhan Kandadai <madhusudhan.opendaylight@...> wrote:
Thanks Reinaldo.

I installed docker image mentioned at and I am able to see the response sent by server in XML after doing "ssh root@localhost -p 1831 -s netconf."

I have created an xml mentioned at and named it as "04-libnetconfd.xml". Have enabled the logs at logback.xml. After restarting the controller, when I issue GET request "http://localhost:8080/restconf/operational/opendaylight-inventory:nodes" I do get the following response:

    "nodes": {
        "node": [
                "id": "libnetconfd"

Sorry for my repeated question.

On Friday, March 28, 2014 6:38 PM, Reinaldo Penno <rapenno@...> wrote:

On Fri, Mar 28, 2014 at 2:45 PM, Madhusudhan Kandadai <madhusudhan.opendaylight@...> wrote:
Thanks Reinaldo. I have two scenarios in testing netconf SB plugin:

(a) Have LINC switch in another VM which actually runs netconf code. I tried to make it work in testing netconf plugin by starting LINC switch in another VM. Have changed IP address, username,port(I used 830 for ssh and put"false" in tcp-only), enabled the log. Unable to recollect where I got stuck. I am still refining it to get more details about this

(b) Have configured netopeer in another VM and followed the steps mentioned at!topic/libnetconf/sVaj8tYYZC0. While doing make && make install for netopeer - server, 

I got this error: .obj/src/server_comm_dbus.o: In function `comm_loop':
server_comm_dbus.c:(.text+0xee3): undefined reference to `server_sessions_get_by_ncid'. This is similar to the one : I could not find any resolution there.

Just checking whether anyone working/worked on this netconf plugin faced this error before? If yes, could you advise on how to overcome this error?


On Tuesday, March 25, 2014 6:04 PM, Reinaldo Penno <rapenno@...> wrote:
okay, there seems a confusion.

ODL has an internal Netconf server. This server is used for configuration of internal ODL stuff. 

In order to test the Netconf SB plug-in you need an _external_ Netconf server device - outside ODL. This can be a number of devices or a stand-alone daemon like netopeer running Netconf Server code.

On Tue, Mar 25, 2014 at 4:42 PM, Madhusudhan Kandadai <madhusudhan.opendaylight@...> wrote:
Hi Reinaldo,

I believe netconf server will be started automatically after starting the controller. Here is the following lines called from config.ini. (Please correct me if I am wrong)
# Netconf startup configuration


netconf.ssh.port=1830 = ./configuration/

so, do you think I have to change the ip address, port#, which are defined at 02-libnetconfd.xml according to the one mentioned above? If not, can you please shed some light on this ? Sorry if this is a basic question.


On Monday, March 24, 2014 8:20 PM, Reinaldo Penno <rapenno@...> wrote:
Which device are you using as a netconf server? You have to substitute the IP address on the example by the IP address of your  netconf device. You need to make sure netconf is running on the device, etc.

On Mon, Mar 24, 2014 at 7:52 PM, Madhusudhan Kandadai <madhusudhan.opendaylight@...> wrote:
Thanks Reinaldo. I actually took the latest controller from wget, created a file named "04-libnetconfd.xml" in opendaylight/configuration/initial

Then started the controller using of13 plugin, but I could not see any notification like this:

2014-02-12 04:42:10.043 PST [pool-23-thread-1] INFO  o.o.c.s.c.n.NetconfDevice#libnetconfd - Starting Netconf Client on: /

Am I doing something wrong?


On Monday, March 24, 2014 7:37 PM, Reinaldo Penno <rapenno@...> wrote:
If the file is correct, nothing else is needed and a netconf session will be established between ODL and netconf server (device)

On Mon, Mar 24, 2014 at 4:45 PM, Madhusudhan Kandadai <madhusudhan.opendaylight@...> wrote:

I am interested in performing testing on netconf plugin. I have netconf server and just want to configure ODL. I have gone through the below links on how to test netconf plugin: and

If I understand correctly:

1. Should I need to configure yumapro-13.04. If yes, I found the documentation at I am trying hard to install yumapro-13.04 and can you point me the right link for installing the same.
2. Once done with the above step, I *think* I can go to this step and follow the sequence in order.

Does anybody worked on testing netconf plugin, so I need to ask the sequence to get familiar in testing netconf plugin.

Thanks in advance!


controller-dev mailing list

Join { to automatically receive all group messages.