OVS versions in use?


JamO Luhrsen
 

btw, we got [3] merged to get our default mininet VMs
upgraded from ovs 2.5 to 2.8 and I checked an ovsdb
and ofp csit job and did not notice anything alarming
with the 2.8 version.

If we need/want to get up to anything newer, we will
need someone to do the work to create that new flavor
of mininet VM.

JamO

On 12/4/19 4:55 PM, JamO Luhrsen via Lists.Opendaylight.Org wrote:

Once upon a time [0], netvirt used to actively track and try to
keep up with ovs releases and keep some sanity around the combinations
to test, but that has lapsed and recently [1] they realized that they
are also running on an old version (2.8)

But, netvirt has their own ways of getting ovs installed when they are
deploying openstack.

I think you might be referring to openflowplugin or ovsdb jobs right?
Those are coming from what we have installed on the VMs were are bringing
up in those stacks.

looking at this osvdb csit output, I think it might be even worse and
using version 2.5.5. We can get all default template CSIT jobs
to use 2.8 quickly with this patch [3]. Obviously, we'd need to take a
look after merging it to make sure nothing new crops up.

I think the bottom line is someone needs to create the new image with
the right releng/builder patch then update the relevant jobs to use
said image.

JamO


[0]
https://docs.opendaylight.org/en/stable-nitrogen/submodules/netvirt/docs/user-guide/support.html
[1]
https://jira.opendaylight.org/browse/NETVIRT-1212
[2]
https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/ovsdb-csit-1node-upstream-southbound-all-magnesium/88/robot-plugin/log.html.gz#s1-s6-t2-k12-k1-k1-k4-k2
[3]
https://git.opendaylight.org/gerrit/c/releng/builder/+/86192

On 12/4/19 2:10 PM, Robert Varga wrote:
Hello,

I have noticed we are using OVS 2.9.2  (released 5/25/2018) in CSIT. Any
particular reason we are not using latest (2.12.90)?

What really is our OVS version support matrix? I would expect us to
verify against last-supported (okay, 2.9.2) as well as a latest stable
(LTS, whatever) and bleeding-edge.

Regards,
Robert

P.S.: OVSDB has this thing in AutoAttach.class:

    // FIXME: To be uncommented when Open vSwitch supports external_ids column
//    @TypedColumn (name="external_ids", method= MethodType.GETCOLUMN, fromVersion="7.11.2")
//    Column<GenericTableSchema, Map<String, String>> getExternalIdsColumn();
//    @TypedColumn (name="external_ids", method= MethodType.SETDATA, fromVersion="7.11.2")
//    void setExternalIds(Map<String, String> externalIds);
without a reference to OVS tracker issue, hence the ask


-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.

View/Reply Online (#13854): https://lists.opendaylight.org/g/integration-dev/message/13854
Mute This Topic: https://lists.opendaylight.org/mt/66548849/535209
Group Owner: integration-dev+owner@...
Unsubscribe: https://lists.opendaylight.org/g/integration-dev/unsub  [jluhrsen@...]
-=-=-=-=-=-=-=-=-=-=-=-


-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.

View/Reply Online (#13855): https://lists.opendaylight.org/g/integration-dev/message/13855
Mute This Topic: https://lists.opendaylight.org/mt/66548849/535209
Group Owner: integration-dev+owner@...
Unsubscribe: https://lists.opendaylight.org/g/integration-dev/unsub  [jluhrsen@...]
-=-=-=-=-=-=-=-=-=-=-=-


JamO Luhrsen
 

Once upon a time [0], netvirt used to actively track and try to
keep up with ovs releases and keep some sanity around the combinations
to test, but that has lapsed and recently [1] they realized that they
are also running on an old version (2.8)

But, netvirt has their own ways of getting ovs installed when they are
deploying openstack.

I think you might be referring to openflowplugin or ovsdb jobs right?
Those are coming from what we have installed on the VMs were are bringing
up in those stacks.

looking at this osvdb csit output, I think it might be even worse and
using version 2.5.5. We can get all default template CSIT jobs
to use 2.8 quickly with this patch [3]. Obviously, we'd need to take a
look after merging it to make sure nothing new crops up.

I think the bottom line is someone needs to create the new image with
the right releng/builder patch then update the relevant jobs to use
said image.

JamO


[0]
https://docs.opendaylight.org/en/stable-nitrogen/submodules/netvirt/docs/user-guide/support.html
[1]
https://jira.opendaylight.org/browse/NETVIRT-1212
[2]
https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/ovsdb-csit-1node-upstream-southbound-all-magnesium/88/robot-plugin/log.html.gz#s1-s6-t2-k12-k1-k1-k4-k2
[3]
https://git.opendaylight.org/gerrit/c/releng/builder/+/86192

On 12/4/19 2:10 PM, Robert Varga wrote:

Hello,

I have noticed we are using OVS 2.9.2  (released 5/25/2018) in CSIT. Any
particular reason we are not using latest (2.12.90)?

What really is our OVS version support matrix? I would expect us to
verify against last-supported (okay, 2.9.2) as well as a latest stable
(LTS, whatever) and bleeding-edge.

Regards,
Robert

P.S.: OVSDB has this thing in AutoAttach.class:

    // FIXME: To be uncommented when Open vSwitch supports external_ids column
//    @TypedColumn (name="external_ids", method= MethodType.GETCOLUMN, fromVersion="7.11.2")
//    Column<GenericTableSchema, Map<String, String>> getExternalIdsColumn();
//    @TypedColumn (name="external_ids", method= MethodType.SETDATA, fromVersion="7.11.2")
//    void setExternalIds(Map<String, String> externalIds);
without a reference to OVS tracker issue, hence the ask


-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.

View/Reply Online (#13854): https://lists.opendaylight.org/g/integration-dev/message/13854
Mute This Topic: https://lists.opendaylight.org/mt/66548849/535209
Group Owner: integration-dev+owner@...
Unsubscribe: https://lists.opendaylight.org/g/integration-dev/unsub  [jluhrsen@...]
-=-=-=-=-=-=-=-=-=-=-=-


Robert Varga
 

Hello,

I have noticed we are using OVS 2.9.2 (released 5/25/2018) in CSIT. Any
particular reason we are not using latest (2.12.90)?

What really is our OVS version support matrix? I would expect us to
verify against last-supported (okay, 2.9.2) as well as a latest stable
(LTS, whatever) and bleeding-edge.

Regards,
Robert

P.S.: OVSDB has this thing in AutoAttach.class:

// FIXME: To be uncommented when Open vSwitch supports external_ids column
// @TypedColumn (name="external_ids", method= MethodType.GETCOLUMN, fromVersion="7.11.2")
// Column<GenericTableSchema, Map<String, String>> getExternalIdsColumn();
// @TypedColumn (name="external_ids", method= MethodType.SETDATA, fromVersion="7.11.2")
// void setExternalIds(Map<String, String> externalIds);
without a reference to OVS tracker issue, hence the ask