controller-csit-1node-akka1-all-{silicon,phosphorus} broken


Luis Gomez
 

I think the simplest is to change the test to download "managed" distribution:


BR/Luis


On Jul 13, 2021, at 9:34 AM, Vratko Polak -X (vrpolak - PANTHEON TECH SRO at Cisco) <vrpolak@...> wrote:

but I forgot which job to trigger (and how) to see if it works.
 
Vratko.
 
From: integration-dev@... <integration-dev@...> On Behalf Of Luis Gomez
Sent: Tuesday, 2021-July-13 18:25
To: Robert Varga <nite@...>
Cc: integration-dev@...
Subject: Re: [integration-dev] controller-csit-1node-akka1-all-{silicon,phosphorus} broken
 

Sure, will do.

> On Jul 13, 2021, at 8:11 AM, Robert Varga <nite@...> wrote:
> 
> Hello Luis, everyone,
> 
> patch
> https://git.opendaylight.org/gerrit/c/integration/distribution/+/95655
> (Change Silicon version to 14.0.0) broke both these jobs:
> 
> https://jenkins.opendaylight.org/releng/job/controller-csit-1node-akka1-all-silicon/
> https://jenkins.opendaylight.org/releng/job/controller-csit-1node-akka1-all-phosphorus/
> 
> because it broke the logic here:
> https://github.com/opendaylight/integration-test/blob/master/csit/libraries/NexusKeywords.robot#L319-L327
> 
> i.e. it now fails with:
> 
>> Evaluating expression '14.0.0 > 14.0 and 14.0.0 < 15.0' failed: SyntaxError: invalid syntax (<string>, line 1)
> 
> I have no idea how to fix this, can you please take a look?
> 
> Thanks,
> Robert
> 




Vratko Polak -X (vrpolak - PANTHEON TECHNOLOGIES at Cisco)
 

I created https://git.opendaylight.org/gerrit/c/integration/test/+/96881

but I forgot which job to trigger (and how) to see if it works.

 

Vratko.

 

From: integration-dev@... <integration-dev@...> On Behalf Of Luis Gomez
Sent: Tuesday, 2021-July-13 18:25
To: Robert Varga <nite@...>
Cc: integration-dev@...
Subject: Re: [integration-dev] controller-csit-1node-akka1-all-{silicon,phosphorus} broken

 

Sure, will do.

> On Jul 13, 2021, at 8:11 AM, Robert Varga <nite@...> wrote:
>
> Hello Luis, everyone,
>
> patch
> https://git.opendaylight.org/gerrit/c/integration/distribution/+/95655
> (Change Silicon version to 14.0.0) broke both these jobs:
>
> https://jenkins.opendaylight.org/releng/job/controller-csit-1node-akka1-all-silicon/
> https://jenkins.opendaylight.org/releng/job/controller-csit-1node-akka1-all-phosphorus/
>
> because it broke the logic here:
> https://github.com/opendaylight/integration-test/blob/master/csit/libraries/NexusKeywords.robot#L319-L327
>
> i.e. it now fails with:
>
>> Evaluating expression '14.0.0 > 14.0 and 14.0.0 < 15.0' failed: SyntaxError: invalid syntax (<string>, line 1)
>
> I have no idea how to fix this, can you please take a look?
>
> Thanks,
> Robert
>



Luis Gomez
 

Sure, will do.

On Jul 13, 2021, at 8:11 AM, Robert Varga <nite@...> wrote:

Hello Luis, everyone,

patch
https://git.opendaylight.org/gerrit/c/integration/distribution/+/95655
(Change Silicon version to 14.0.0) broke both these jobs:

https://jenkins.opendaylight.org/releng/job/controller-csit-1node-akka1-all-silicon/
https://jenkins.opendaylight.org/releng/job/controller-csit-1node-akka1-all-phosphorus/

because it broke the logic here:
https://github.com/opendaylight/integration-test/blob/master/csit/libraries/NexusKeywords.robot#L319-L327

i.e. it now fails with:

Evaluating expression '14.0.0 > 14.0 and 14.0.0 < 15.0' failed: SyntaxError: invalid syntax (<string>, line 1)
I have no idea how to fix this, can you please take a look?

Thanks,
Robert


Robert Varga
 

Hello Luis, everyone,

patch
https://git.opendaylight.org/gerrit/c/integration/distribution/+/95655
(Change Silicon version to 14.0.0) broke both these jobs:

https://jenkins.opendaylight.org/releng/job/controller-csit-1node-akka1-all-silicon/
https://jenkins.opendaylight.org/releng/job/controller-csit-1node-akka1-all-phosphorus/

because it broke the logic here:
https://github.com/opendaylight/integration-test/blob/master/csit/libraries/NexusKeywords.robot#L319-L327

i.e. it now fails with:

Evaluating expression '14.0.0 > 14.0 and 14.0.0 < 15.0' failed: SyntaxError: invalid syntax (<string>, line 1)
I have no idea how to fix this, can you please take a look?

Thanks,
Robert