Re: [OpenDaylight TSC] CSIT status in proposed topic:neon-mri ("Weather Item" TSC-132)


Robert Varga
 

features-core-4.1.5 ... wrong base karaf distro, pulled from odlparent-3.1.0-3, not 4.0.2.

Sent from my BlackBerry - the most secure mobile device - via the Orange Network
From: ecelgp@...

Sent: October 10, 2018 23:59
To: vorburger@...
Cc: nite@...; aaa-dev@...; tompantelis@...; netvirt-dev@...; tsc@...; netconf-dev@...; skitt@...; jluhrsen@...; jluhrsen@...
Subject: Re: [OpenDaylight TSC] CSIT status in proposed topic:neon-mri ("Weather Item" TSC-132)

Just to be clear, this is not a multi-patch job issue but a controller version integration issue, right?

On Oct 10, 2018, at 2:47 PM, Michael Vorburger <vorburger@...> wrote:

- netconf-dev, as it's no longer their problem:

On Wed, Oct 10, 2018 at 1:35 PM Michael Vorburger <vorburger@...> wrote:
On Wed, Oct 10, 2018 at 12:30 PM Robert Varga <nite@...> wrote:
On 10/10/2018 00:42, Michael Vorburger wrote:
> The SFT in AAA should have caught this, but apparently didn't... perhaps
> it only appears in an integration/distribution Karaf? Tom or Robert, is
> this something you would be willing to dig more into?

int/dist is just another project, hence it obviously needs a neon-mri
patch: https://git.opendaylight.org/gerrit/76817.

Oh! Right. - Thanks a lot for puttting that together.

Luis, I want to run a new multipatch job incl. c/76817 ... have just kicked off new

after having sorted out a few other problems, we're unfortunately still back to this issue:

2018-10-10T19:21:48,049 | ERROR | pool-1-thread-2  | BootFeaturesInstaller            | 8 - org.apache.karaf.features.core - 4.1.5 | Error installing boot features
org.osgi.service.resolver.ResolutionException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=odl-integration-compatible-with-all; type=karaf.feature; version="[0.10.0.SNAPSHOT,0.10.0.SNAPSHOT]"; filter:="(&(osgi.identity=odl-integration-compatible-with-all)(type=karaf.feature)(version>=0.10.0.SNAPSHOT)(version<=0.10.0.SNAPSHOT))" [caused by: Unable to resolve odl-integration-compatible-with-all/0.10.0.SNAPSHOT: missing requirement [odl-integration-compatible-with-all/0.10.0.SNAPSHOT] osgi.identity; osgi.identity=odl-ovsdb-southbound-impl; type=karaf.feature; version="[1.8.0.SNAPSHOT,1.8.0.SNAPSHOT]" [caused by: Unable to resolve odl-ovsdb-southbound-impl/1.8.0.SNAPSHOT: missing requirement [odl-ovsdb-southbound-impl/1.8.0.SNAPSHOT] osgi.identity; osgi.identity=odl-ovsdb-library; type=karaf.feature; version="[1.8.0.SNAPSHOT,1.8.0.SNAPSHOT]" [caused by: Unable to resolve odl-ovsdb-library/1.8.0.SNAPSHOT: missing requirement [odl-ovsdb-library/1.8.0.SNAPSHOT] osgi.identity; osgi.identity=org.opendaylight.ovsdb.library; type=osgi.bundle; version="[1.8.0.SNAPSHOT,1.8.0.SNAPSHOT]"; resolution:=mandatory [caused by: Unable to resolve org.opendaylight.ovsdb.library/1.8.0.SNAPSHOT: missing requirement [org.opendaylight.ovsdb.library/1.8.0.SNAPSHOT] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.opendaylight.aaa.cert.api)(version>=0.9.0)(!(version>=1.0.0)))" [caused by: Unable to resolve org.opendaylight.aaa.cert/0.9.0.SNAPSHOT: missing requirement [org.opendaylight.aaa.cert/0.9.0.SNAPSHOT] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.bouncycastle.asn1)(version>=1.60.0)(!(version>=2.0.0)))"]]]]]


Join z.archive.aaa-dev@lists.opendaylight.org to automatically receive all group messages.