issue with aaa credentials model


Colin Dixon <colin@...>
 

While running the single feature test on the TTP repo, I keep seeing this error message. I'm guessing it's a bug in AAA.

2015-03-18 15:42:05,994 | WARN  | (3)-10.106.3.107 | YangParserImpl                   | 190 - org.opendaylight.yangtools.yang-parser-impl - 0.7.0.SNAPSHOT | Error in module credential-store at line 43: Failed to resolve node urn:opendaylight:params:xml:ns:yang:aaa:credential-store:descripton Extension point. Contains the data specific to the credential type.: no such extension definition found.

--Colin


Krell, Sherry <sherry.krell@...>
 

FYI,

 

I rebased the patch to re-enable the features-test in AAA today to address merge conflicts. In the process, I discovered 2 of the features that had been added for M3 were failing the tests. I fixed the test failures as part of the updated patch for features-test. It’s out for review: https://git.opendaylight.org/gerrit/#/c/15743/

 

 

From: aaa-dev-bounces@... [mailto:aaa-dev-bounces@...] On Behalf Of Colin Dixon
Sent: Wednesday, March 18, 2015 3:04 PM
To: release@...; aaa-dev@...
Subject: [Aaa-dev] issue with aaa credentials model

 

While running the single feature test on the TTP repo, I keep seeing this error message. I'm guessing it's a bug in AAA.

2015-03-18 15:42:05,994 | WARN  | (3)-10.106.3.107 | YangParserImpl                   | 190 - org.opendaylight.yangtools.yang-parser-impl - 0.7.0.SNAPSHOT | Error in module credential-store at line 43: Failed to resolve node urn:opendaylight:params:xml:ns:yang:aaa:credential-store:descripton Extension point. Contains the data specific to the credential type.: no such extension definition found.

--Colin


Edward Warnicke <hagbard@...>
 

Sherry, 

It looks like aaa isn't running SingleFeatureTest as part of its verify job... is that true:


Ed

On Wed, Mar 18, 2015 at 5:10 PM, Krell, Sherry <sherry.krell@...> wrote:

FYI,

 

I rebased the patch to re-enable the features-test in AAA today to address merge conflicts. In the process, I discovered 2 of the features that had been added for M3 were failing the tests. I fixed the test failures as part of the updated patch for features-test. It’s out for review: https://git.opendaylight.org/gerrit/#/c/15743/

 

 

From: aaa-dev-bounces@... [mailto:aaa-dev-bounces@...] On Behalf Of Colin Dixon
Sent: Wednesday, March 18, 2015 3:04 PM
To: release@...; aaa-dev@...
Subject: [Aaa-dev] issue with aaa credentials model

 

While running the single feature test on the TTP repo, I keep seeing this error message. I'm guessing it's a bug in AAA.

2015-03-18 15:42:05,994 | WARN  | (3)-10.106.3.107 | YangParserImpl                   | 190 - org.opendaylight.yangtools.yang-parser-impl - 0.7.0.SNAPSHOT | Error in module credential-store at line 43: Failed to resolve node urn:opendaylight:params:xml:ns:yang:aaa:credential-store:descripton Extension point. Contains the data specific to the credential type.: no such extension definition found.

--Colin


_______________________________________________
aaa-dev mailing list
aaa-dev@...
https://lists.opendaylight.org/mailman/listinfo/aaa-dev



Krell, Sherry <sherry.krell@...>
 

Hi Ed,

 

Yes. The patch I referenced is supposed to fix that.

 

From: Edward Warnicke [mailto:hagbard@...]
Sent: Wednesday, March 18, 2015 3:15 PM
To: Krell, Sherry
Cc: Colin Dixon; release@...; aaa-dev@...
Subject: Re: [Aaa-dev] issue with aaa credentials model

 

Sherry, 

 

It looks like aaa isn't running SingleFeatureTest as part of its verify job... is that true:

 

 

Ed

 

On Wed, Mar 18, 2015 at 5:10 PM, Krell, Sherry <sherry.krell@...> wrote:

FYI,

 

I rebased the patch to re-enable the features-test in AAA today to address merge conflicts. In the process, I discovered 2 of the features that had been added for M3 were failing the tests. I fixed the test failures as part of the updated patch for features-test. It’s out for review: https://git.opendaylight.org/gerrit/#/c/15743/

 

 

From: aaa-dev-bounces@... [mailto:aaa-dev-bounces@...] On Behalf Of Colin Dixon
Sent: Wednesday, March 18, 2015 3:04 PM
To: release@...; aaa-dev@...
Subject: [Aaa-dev] issue with aaa credentials model

 

While running the single feature test on the TTP repo, I keep seeing this error message. I'm guessing it's a bug in AAA.

2015-03-18 15:42:05,994 | WARN  | (3)-10.106.3.107 | YangParserImpl                   | 190 - org.opendaylight.yangtools.yang-parser-impl - 0.7.0.SNAPSHOT | Error in module credential-store at line 43: Failed to resolve node urn:opendaylight:params:xml:ns:yang:aaa:credential-store:descripton Extension point. Contains the data specific to the credential type.: no such extension definition found.

--Colin


_______________________________________________
aaa-dev mailing list
aaa-dev@...
https://lists.opendaylight.org/mailman/listinfo/aaa-dev