odlparent 2.0.2 released


Stephen Kitt <skitt@...>
 

Hi,

odlparent 2.0.2 has been released. The changes since 2.0.1 are as
follows:
* https://git.opendaylight.org/gerrit/59932 — ensure script permissions
are correct (https://bugs.opendaylight.org/show_bug.cgi?id=8798)
* https://git.opendaylight.org/gerrit/59939 — preserve our patches in
the final Karaf distribution
(https://bugs.opendaylight.org/show_bug.cgi?id=8799)
* https://git.opendaylight.org/gerrit/59837 — disable SFT on feature
repositories by default

odlparent 2.0.2 is once again capable of producing a working
distribution, unlike 2.0.1 (sorry!). It has passed CSIT on NetVirt, and
a round of local testing.

The only blocking issues fixed in this release affect karaf4-parent, so
the upgrade requirements are minimal:
* integration/distribution needs to upgrade to 2.0.2
* all project modules inheriting from karaf4-parent and currently using
2.0.1 need to upgrade to 2.0.2

Apart from that, most projects are free to upgrade as they wish; the
exceptions are aaa and netconf which need to upgrade to at least 2.0.1
to ensure the Bouncy Castle dependencies are coherent. But I would
strongly encourage all projects to upgrade to 2.0.2 at their earliest
convenience.

(I have tested various mixed configurations with no issue, including
Robert’s proposed test using restconf with a 2.0.2 dependency and
bgpcep with a 2.0.1 dependency, and simultaneously loading features.)

Regards,

--
Stephen Kitt
Principal Software Engineer, Office of Technology
Red Hat