[Odlparent-dev] Jetty version problem in odlparent 3


Stephen Kitt <skitt@...>
 

On Fri, 19 Jan 2018 17:00:39 +0100
Stephen Kitt <skitt@...> wrote:
On Fri, 19 Jan 2018 16:55:52 +0100
Stephen Kitt <skitt@...> wrote:
On Fri, 19 Jan 2018 13:49:03 +0000
Martin Dindoffer <Martin.Dindoffer@...> wrote:
Seems like we should either patch jetty dependency back to 9.2.19
or make aaa/restconf behave nicely when updating jetty
underneath.
... or perhaps make SXP depend on pax-http-jetty instead; does that
work any better?
Or better yet, on odl-karaf-feat-jetty which is what ends up pulling
in pax-http-jetty, and which is what AAA uses.
On the AAA side of things, https://git.opendaylight.org/gerrit/67357
will help — it drops the explicit Jetty dependencies from the
odl-aaa-shiro feature.

Regards,

Stephen