[SSL-RESTCONF] Query about etc/custom.properties


A Vamsikrishna
 

Hi Ryan / Evan / Ignacio,

 

I am able to make SSL-RESTCONF connection by modifying C:\master\distribution\karaf\target\assembly\etc\org.ops4j.pax.web as below:

 

org.osgi.service.http.secure.enabled=true

org.osgi.service.http.port.secure=8443

org.ops4j.pax.web.ssl.keystore=configuration/ssl/ctl.jks

org.ops4j.pax.web.ssl.truststore=configuration/ssl/truststore.jks

org.ops4j.pax.web.ssl.password=opendaylight

org.ops4j.pax.web.ssl.keypassword=opendaylight

 

I am just wondering if there is any way to make the same work with C:\master\distribution\karaf\target\assembly\etc\custom.properties without modifying org.ops4j.pax.web

 

Can you please help me out with this ?

 

Thanks,

Vamsi


A Vamsikrishna
 

Hi Ryan / Evan / Ignacio,

 

I am able to make the SSL-RESTCONF work with custom.properties with the same changes I have put in org.ops4j.pax.web

 

That is:

 

org.osgi.service.http.secure.enabled=true

org.osgi.service.http.port.secure=8443

org.ops4j.pax.web.ssl.keystore=configuration/ssl/ctl.jks

org.ops4j.pax.web.ssl.truststore=configuration/ssl/truststore.jks

org.ops4j.pax.web.ssl.password=opendaylight

org.ops4j.pax.web.ssl.keypassword=opendaylight

 

org.ops4j.pax.web remains unchanged.

 

curl seems to be working fine:

 

stack@ubuntu:/etc/openvswitch$ curl -l http://192.168.56.1:8181/restconf/operational/network-topology:network-topology/ --user admin:admin

{"network-topology":{"topology":[{"topology-id":"flow:1"},{"topology-id":"ovsdb:1"},{"topology-id":"netvirt:1"},{"topology-id":"hwvtep:1"}]}}

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$ curl -l -k https://192.168.56.1:8443/restconf/operational/network-topology:network-topology/ --user admin:admin

{"network-topology":{"topology":[{"topology-id":"flow:1"},{"topology-id":"ovsdb:1"},{"topology-id":"netvirt:1"},{"topology-id":"hwvtep:1"}]}}

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

 

But if I try to open in browser I am seeing below errors:

 

 

 

Any idea how to fix this ??

 

Thanks,

Vamsi

 

 

From: A Vamsikrishna
Sent: Wednesday, January 31, 2018 3:55 PM
To: 'Ryan Goulding' <ryandgoulding@...>; 'Ignacio Dominguez Martinez-Casanueva' <i.dominguezm@...>; 'Evan Zeller' <ezeller@...>
Cc: aaa-dev@...
Subject: [SSL-RESTCONF] Query about etc/custom.properties

 

Hi Ryan / Evan / Ignacio,

 

I am able to make SSL-RESTCONF connection by modifying C:\master\distribution\karaf\target\assembly\etc\org.ops4j.pax.web as below:

 

org.osgi.service.http.secure.enabled=true

org.osgi.service.http.port.secure=8443

org.ops4j.pax.web.ssl.keystore=configuration/ssl/ctl.jks

org.ops4j.pax.web.ssl.truststore=configuration/ssl/truststore.jks

org.ops4j.pax.web.ssl.password=opendaylight

org.ops4j.pax.web.ssl.keypassword=opendaylight

 

I am just wondering if there is any way to make the same work with C:\master\distribution\karaf\target\assembly\etc\custom.properties without modifying org.ops4j.pax.web

 

Can you please help me out with this ?

 

Thanks,

Vamsi


Ignacio Dominguez Martinez-Casanueva <i.dominguezm@...>
 

Hi Vamsi,

Please make sure you have installed `odl-mdsal-apidocs` feature. It seems the REST endpoint you are trying to access (APIDOCS EXPLORER) is not available in OpenDaylight.

opendaylight-user@root>feature:list | grep apidoc
odl-mdsal-apidocs                                | 1.6.1            | x        | Started     | odl-mdsal-apidocs                                | OpenDaylight :: MDSAL :: APIDOCS


If it is installed correctly, you should see from karaf that its API REST service running.

opendaylight-user@root>web:list
ID  | State       | Web-State   | Level | Web-ContextPath           | Name
---------------------------------------------------------------------------------------------------------------------
...

317 | Active      | Deployed    | 80    | /apidoc                   | MD SAL Rest Api Doc Generator (1.6.1)

...

Best regards,
Ignacio.

On 31.01.2018 12:18, A Vamsikrishna wrote:

Hi Ryan / Evan / Ignacio,

 

I am able to make the SSL-RESTCONF work with custom.properties with the same changes I have put in org.ops4j.pax.web

 

That is:

 

org.osgi.service.http.secure.enabled=true

org.osgi.service.http.port.secure=8443

org.ops4j.pax.web.ssl.keystore=configuration/ssl/ctl.jks

org.ops4j.pax.web.ssl.truststore=configuration/ssl/truststore.jks

org.ops4j.pax.web.ssl.password=opendaylight

org.ops4j.pax.web.ssl.keypassword=opendaylight

 

org.ops4j.pax.web remains unchanged.

 

curl seems to be working fine:

 

stack@ubuntu:/etc/openvswitch$ curl -l http://192.168.56.1:8181/restconf/operational/network-topology:network-topology/ --user admin:admin

{"network-topology":{"topology":[{"topology-id":"flow:1"},{"topology-id":"ovsdb:1"},{"topology-id":"netvirt:1"},{"topology-id":"hwvtep:1"}]}}

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$ curl -l -k https://192.168.56.1:8443/restconf/operational/network-topology:network-topology/ --user admin:admin

{"network-topology":{"topology":[{"topology-id":"flow:1"},{"topology-id":"ovsdb:1"},{"topology-id":"netvirt:1"},{"topology-id":"hwvtep:1"}]}}

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

 

But if I try to open in browser I am seeing below errors:

 

 

 

Any idea how to fix this ??

 

Thanks,

Vamsi

 

 

From: A Vamsikrishna
Sent: Wednesday, January 31, 2018 3:55 PM
To: 'Ryan Goulding' <ryandgoulding@...>; 'Ignacio Dominguez Martinez-Casanueva' <i.dominguezm@...>; 'Evan Zeller' <ezeller@...>
Cc: aaa-dev@...
Subject: [SSL-RESTCONF] Query about etc/custom.properties

 

Hi Ryan / Evan / Ignacio,

 

I am able to make SSL-RESTCONF connection by modifying C:\master\distribution\karaf\target\assembly\etc\org.ops4j.pax.web as below:

 

org.osgi.service.http.secure.enabled=true

org.osgi.service.http.port.secure=8443

org.ops4j.pax.web.ssl.keystore=configuration/ssl/ctl.jks

org.ops4j.pax.web.ssl.truststore=configuration/ssl/truststore.jks

org.ops4j.pax.web.ssl.password=opendaylight

org.ops4j.pax.web.ssl.keypassword=opendaylight

 

I am just wondering if there is any way to make the same work with C:\master\distribution\karaf\target\assembly\etc\custom.properties without modifying org.ops4j.pax.web

 

Can you please help me out with this ?

 

Thanks,

Vamsi



A Vamsikrishna
 

Hi Ignacio,

 

I have installed Mdsal-apidocs  feature but it’s showing as “Deploying” which ideally should be “Deployed”.

 

opendaylight-user@root>feature:install odl-mdsal-apidocs

opendaylight-user@root>

opendaylight-user@root>

opendaylight-user@root>feature:list -i | grep -i apidoc

odl-mdsal-apidocs                               | 1.7.0.SNAPSHOT   | x        | Started | odl-mdsal-apidocs                               | OpenDaylight :: MDSAL :: APIDOCS

opendaylight-user@root>

opendaylight-user@root>

opendaylight-user@root>web:list

ID  | State       | Web-State   | Level | Web-ContextPath           | Name

-------------------------------------------------------------------------------------------------------------------------------

179 | Active      | Deploying   | 80    | /auth                     | org.opendaylight.aaa.aaa-shiro (0.7.0.SNAPSHOT)

313 | Active      | Deploying   | 80    | /restconf                 | MD SAL Restconf Connector (1.7.0.SNAPSHOT)

351 | Active      | Deploying   | 80    | /controller/nb/v2/neutron | org.opendaylight.neutron.northbound-api (0.10.0.SNAPSHOT)

441 | Active      | Deploying   | 80    | /apidoc                   | MD SAL Rest Api Doc Generator (1.7.0.SNAPSHOT)

opendaylight-user@root>

opendaylight-user@root>

 

Any suggestions on this ?

 

Thanks,

Vamsi

 

From: Ignacio Dominguez Martinez-Casanueva [mailto:i.dominguezm@...]
Sent: Wednesday, January 31, 2018 5:38 PM
To: A Vamsikrishna <a.vamsikrishna@...>; Ryan Goulding <ryandgoulding@...>; Evan Zeller <ezeller@...>
Cc: aaa-dev@...
Subject: Re: [SSL-RESTCONF] Query about etc/custom.properties

 

Hi Vamsi,

Please make sure you have installed `odl-mdsal-apidocs` feature. It seems the REST endpoint you are trying to access (APIDOCS EXPLORER) is not available in OpenDaylight.

opendaylight-user@root>feature:list | grep apidoc
odl-mdsal-apidocs                                | 1.6.1            | x        | Started     | odl-mdsal-apidocs                                | OpenDaylight :: MDSAL :: APIDOCS

 

If it is installed correctly, you should see from karaf that its API REST service running.

opendaylight-user@root>web:list
ID  | State       | Web-State   | Level | Web-ContextPath           | Name
---------------------------------------------------------------------------------------------------------------------
...

317 | Active      | Deployed    | 80    | /apidoc                   | MD SAL Rest Api Doc Generator (1.6.1)

...

Best regards,
Ignacio.

On 31.01.2018 12:18, A Vamsikrishna wrote:

Hi Ryan / Evan / Ignacio,

 

I am able to make the SSL-RESTCONF work with custom.properties with the same changes I have put in org.ops4j.pax.web

 

That is:

 

org.osgi.service.http.secure.enabled=true

org.osgi.service.http.port.secure=8443

org.ops4j.pax.web.ssl.keystore=configuration/ssl/ctl.jks

org.ops4j.pax.web.ssl.truststore=configuration/ssl/truststore.jks

org.ops4j.pax.web.ssl.password=opendaylight

org.ops4j.pax.web.ssl.keypassword=opendaylight

 

org.ops4j.pax.web remains unchanged.

 

curl seems to be working fine:

 

stack@ubuntu:/etc/openvswitch$ curl -l http://192.168.56.1:8181/restconf/operational/network-topology:network-topology/ --user admin:admin

{"network-topology":{"topology":[{"topology-id":"flow:1"},{"topology-id":"ovsdb:1"},{"topology-id":"netvirt:1"},{"topology-id":"hwvtep:1"}]}}

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$ curl -l -k https://192.168.56.1:8443/restconf/operational/network-topology:network-topology/ --user admin:admin

{"network-topology":{"topology":[{"topology-id":"flow:1"},{"topology-id":"ovsdb:1"},{"topology-id":"netvirt:1"},{"topology-id":"hwvtep:1"}]}}

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

 

But if I try to open in browser I am seeing below errors:

 

 

 

Any idea how to fix this ??

 

Thanks,

Vamsi

 

 

From: A Vamsikrishna
Sent: Wednesday, January 31, 2018 3:55 PM
To: 'Ryan Goulding' <ryandgoulding@...>; 'Ignacio Dominguez Martinez-Casanueva' <i.dominguezm@...>; 'Evan Zeller' <ezeller@...>
Cc: aaa-dev@...
Subject: [SSL-RESTCONF] Query about etc/custom.properties

 

Hi Ryan / Evan / Ignacio,

 

I am able to make SSL-RESTCONF connection by modifying C:\master\distribution\karaf\target\assembly\etc\org.ops4j.pax.web as below:

 

org.osgi.service.http.secure.enabled=true

org.osgi.service.http.port.secure=8443

org.ops4j.pax.web.ssl.keystore=configuration/ssl/ctl.jks

org.ops4j.pax.web.ssl.truststore=configuration/ssl/truststore.jks

org.ops4j.pax.web.ssl.password=opendaylight

org.ops4j.pax.web.ssl.keypassword=opendaylight

 

I am just wondering if there is any way to make the same work with C:\master\distribution\karaf\target\assembly\etc\custom.properties without modifying org.ops4j.pax.web

 

Can you please help me out with this ?

 

Thanks,

Vamsi

 


Ignacio Dominguez Martinez-Casanueva <i.dominguezm@...>
 

Hi Vamsi,

I have faced this same error a long time ago (not in Nitrogen though), but at the time I wasn't able to figure out the root cause. Which ODL version are you using? Nitrogen SR1?

Have you tried cleaning OpenDaylight and restarting the service? I usually follow this procedure (in CentOS):

    rm -rf <odl_folder>/data/ <odl_folder>/journal/ <odl_folder>/instances/

and then:

    systemctl restart opendaylight.service

Afterwards, please check karaf.log and wait until ODL has finished booting.

If this does not solve the problem, I don't know what else you could do. Maybe this thread should be moved to a more related mailing list.

Does anyone know what could be the reason of ODL stuck with "Deploying"?

Best regards,
Ignacio.

On 01.02.2018 11:34, A Vamsikrishna wrote:

Hi Ignacio,

 

I have installed Mdsal-apidocs  feature but it’s showing as “Deploying” which ideally should be “Deployed”.

 

opendaylight-user@root>feature:install odl-mdsal-apidocs

opendaylight-user@root>

opendaylight-user@root>

opendaylight-user@root>feature:list -i | grep -i apidoc

odl-mdsal-apidocs                               | 1.7.0.SNAPSHOT   | x        | Started | odl-mdsal-apidocs                               | OpenDaylight :: MDSAL :: APIDOCS

opendaylight-user@root>

opendaylight-user@root>

opendaylight-user@root>web:list

ID  | State       | Web-State   | Level | Web-ContextPath           | Name

-------------------------------------------------------------------------------------------------------------------------------

179 | Active      | Deploying   | 80    | /auth                     | org.opendaylight.aaa.aaa-shiro (0.7.0.SNAPSHOT)

313 | Active      | Deploying   | 80    | /restconf                 | MD SAL Restconf Connector (1.7.0.SNAPSHOT)

351 | Active      | Deploying   | 80    | /controller/nb/v2/neutron | org.opendaylight.neutron.northbound-api (0.10.0.SNAPSHOT)

441 | Active      | Deploying   | 80    | /apidoc                   | MD SAL Rest Api Doc Generator (1.7.0.SNAPSHOT)

opendaylight-user@root>

opendaylight-user@root>

 

Any suggestions on this ?

 

Thanks,

Vamsi

 

From: Ignacio Dominguez Martinez-Casanueva [mailto:i.dominguezm@...]
Sent: Wednesday, January 31, 2018 5:38 PM
To: A Vamsikrishna <a.vamsikrishna@...>; Ryan Goulding <ryandgoulding@...>; Evan Zeller <ezeller@...>
Cc: aaa-dev@...
Subject: Re: [SSL-RESTCONF] Query about etc/custom.properties

 

Hi Vamsi,

Please make sure you have installed `odl-mdsal-apidocs` feature. It seems the REST endpoint you are trying to access (APIDOCS EXPLORER) is not available in OpenDaylight.

opendaylight-user@root>feature:list | grep apidoc
odl-mdsal-apidocs                                | 1.6.1            | x        | Started     | odl-mdsal-apidocs                                | OpenDaylight :: MDSAL :: APIDOCS

 

If it is installed correctly, you should see from karaf that its API REST service running.

opendaylight-user@root>web:list
ID  | State       | Web-State   | Level | Web-ContextPath           | Name
---------------------------------------------------------------------------------------------------------------------
...

317 | Active      | Deployed    | 80    | /apidoc                   | MD SAL Rest Api Doc Generator (1.6.1)

...

Best regards,
Ignacio.

On 31.01.2018 12:18, A Vamsikrishna wrote:

Hi Ryan / Evan / Ignacio,

 

I am able to make the SSL-RESTCONF work with custom.properties with the same changes I have put in org.ops4j.pax.web

 

That is:

 

org.osgi.service.http.secure.enabled=true

org.osgi.service.http.port.secure=8443

org.ops4j.pax.web.ssl.keystore=configuration/ssl/ctl.jks

org.ops4j.pax.web.ssl.truststore=configuration/ssl/truststore.jks

org.ops4j.pax.web.ssl.password=opendaylight

org.ops4j.pax.web.ssl.keypassword=opendaylight

 

org.ops4j.pax.web remains unchanged.

 

curl seems to be working fine:

 

stack@ubuntu:/etc/openvswitch$ curl -l http://192.168.56.1:8181/restconf/operational/network-topology:network-topology/ --user admin:admin

{"network-topology":{"topology":[{"topology-id":"flow:1"},{"topology-id":"ovsdb:1"},{"topology-id":"netvirt:1"},{"topology-id":"hwvtep:1"}]}}

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$ curl -l -k https://192.168.56.1:8443/restconf/operational/network-topology:network-topology/ --user admin:admin

{"network-topology":{"topology":[{"topology-id":"flow:1"},{"topology-id":"ovsdb:1"},{"topology-id":"netvirt:1"},{"topology-id":"hwvtep:1"}]}}

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

stack@ubuntu:/etc/openvswitch$

 

But if I try to open in browser I am seeing below errors:

 

 

 

Any idea how to fix this ??

 

Thanks,

Vamsi

 

 

From: A Vamsikrishna
Sent: Wednesday, January 31, 2018 3:55 PM
To: 'Ryan Goulding' <ryandgoulding@...>; 'Ignacio Dominguez Martinez-Casanueva' <i.dominguezm@...>; 'Evan Zeller' <ezeller@...>
Cc: aaa-dev@...
Subject: [SSL-RESTCONF] Query about etc/custom.properties

 

Hi Ryan / Evan / Ignacio,

 

I am able to make SSL-RESTCONF connection by modifying C:\master\distribution\karaf\target\assembly\etc\org.ops4j.pax.web as below:

 

org.osgi.service.http.secure.enabled=true

org.osgi.service.http.port.secure=8443

org.ops4j.pax.web.ssl.keystore=configuration/ssl/ctl.jks

org.ops4j.pax.web.ssl.truststore=configuration/ssl/truststore.jks

org.ops4j.pax.web.ssl.password=opendaylight

org.ops4j.pax.web.ssl.keypassword=opendaylight

 

I am just wondering if there is any way to make the same work with C:\master\distribution\karaf\target\assembly\etc\custom.properties without modifying org.ops4j.pax.web

 

Can you please help me out with this ?

 

Thanks,

Vamsi