[release] autorelease carbon build failing on alto tests


Anil Belur <abelur@...>
 

Hello,

Carbon autorelease build is failing on tests. Please refer logs in [1.].

[1.]
https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/167/

Thanks,
Anil


01:57:36 [INFO] features-alto-release ..............................
FAILURE [07:27 min]
...
01:57:36 Tests in error:
01:57:36 Can't install feature odl-alto-auto-maps/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [361]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-basic/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-core/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-manual-maps/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-northbound/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-release/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-simpleecs/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [369]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-simpleird/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature
odl-alto-standard-northbound-route/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [352]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36


Gao Kai <gaok12@...>
 

Hi Anil,

Thanks for the notice. We'll look into that.

Regards,
Kai

-----原始邮件-----
发件人: "Anil Belur" <abelur@...>
发送时间: 2017-02-20 09:49:48 (星期一)
收件人: "release@..." <release@...>, alto-dev@...
抄送:
主题: [alto-dev] [release] autorelease carbon build failing on alto tests

Hello,

Carbon autorelease build is failing on tests. Please refer logs in [1.].

[1.]
https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/167/

Thanks,
Anil


01:57:36 [INFO] features-alto-release ..............................
FAILURE [07:27 min]
...
01:57:36 Tests in error:
01:57:36 Can't install feature odl-alto-auto-maps/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [361]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-basic/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-core/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-manual-maps/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-northbound/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-release/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-simpleecs/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [369]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature odl-alto-simpleird/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36 Can't install feature
odl-alto-standard-northbound-route/0.4.0-Carbon:
01:57:36 Could not start bundle
mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
"org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [352]"
could not be resolved. Reason: Missing Constraint: Import-Package:
org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
01:57:36



Anil Belur <abelur@...>
 

Hi, 

Autorelease carbon has been failing for on the same issue more than a week. 
Can you please resolve the issue by disabling the tests or we will have to remove alto project from autolrease until the issue gets resolved. 
Please resolve the issue latest by tomorrow, since we want autorelease build not to be blocked.

Thanks,
Anil

On Tue, Feb 21, 2017 at 6:01 AM, Gao Kai <gaok12@...> wrote:
Hi Anil,

Thanks for the notice. We'll look into that.

Regards,
Kai


> -----原始邮件-----
> 发件人: "Anil Belur" <abelur@...>
> 发送时间: 2017-02-20 09:49:48 (星期一)
> 收件人: "release@....org" <release@....org>, alto-dev@....org
> 抄送:
> 主题: [alto-dev] [release] autorelease carbon build failing on alto tests
>
> Hello,
>
> Carbon autorelease build is failing on tests. Please refer logs in [1.].
>
> [1.]
> https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/167/
>
> Thanks,
> Anil
>
>
> 01:57:36 [INFO] features-alto-release ..............................
> FAILURE [07:27 min]
> ...
> 01:57:36 Tests in error:
> 01:57:36   Can't install feature odl-alto-auto-maps/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [361]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-basic/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-core/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-manual-maps/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-northbound/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-release/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-simpleecs/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [369]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-simpleird/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature
> odl-alto-standard-northbound-route/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [352]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36
>
>
>






Thanh Ha <thanh.ha@...>
 

Hi Kai,

Is there an ETA one when the tests can be fixed?

Ideally we'd like the tests fixed rather than disabled. If we cannot get this resolved soon we will need to remove Alto from the Autorelease build as it's blocking us from building the Carbon release.

Thanks,
Thanh


On Sun, Feb 26, 2017 at 10:27 PM, Anil Belur <abelur@...> wrote:
Hi, 

Autorelease carbon has been failing for on the same issue more than a week. 
Can you please resolve the issue by disabling the tests or we will have to remove alto project from autolrease until the issue gets resolved. 
Please resolve the issue latest by tomorrow, since we want autorelease build not to be blocked.

Thanks,
Anil

On Tue, Feb 21, 2017 at 6:01 AM, Gao Kai <gaok12@...> wrote:
Hi Anil,

Thanks for the notice. We'll look into that.

Regards,
Kai


> -----原始邮件-----
> 发件人: "Anil Belur" <abelur@...>
> 发送时间: 2017-02-20 09:49:48 (星期一)
> 收件人: "release@...g" <release@...g>, alto-dev@...g
> 抄送:
> 主题: [alto-dev] [release] autorelease carbon build failing on alto tests
>
> Hello,
>
> Carbon autorelease build is failing on tests. Please refer logs in [1.].
>
> [1.]
> https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/167/
>
> Thanks,
> Anil
>
>
> 01:57:36 [INFO] features-alto-release ..............................
> FAILURE [07:27 min]
> ...
> 01:57:36 Tests in error:
> 01:57:36   Can't install feature odl-alto-auto-maps/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [361]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-basic/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-core/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-manual-maps/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-northbound/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-release/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-simpleecs/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [369]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-simpleird/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature
> odl-alto-standard-northbound-route/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [352]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36


Jensen Zhang
 

Hi Thanh,

Sorry about that. We are working on this issue.

Thanks,
Jensen

On Feb 27, 2017 11:43 AM, "Thanh Ha" <thanh.ha@...> wrote:
Hi Kai,

Is there an ETA one when the tests can be fixed?

Ideally we'd like the tests fixed rather than disabled. If we cannot get this resolved soon we will need to remove Alto from the Autorelease build as it's blocking us from building the Carbon release.

Thanks,
Thanh


On Sun, Feb 26, 2017 at 10:27 PM, Anil Belur <abelur@...> wrote:
Hi, 

Autorelease carbon has been failing for on the same issue more than a week. 
Can you please resolve the issue by disabling the tests or we will have to remove alto project from autolrease until the issue gets resolved. 
Please resolve the issue latest by tomorrow, since we want autorelease build not to be blocked.

Thanks,
Anil

On Tue, Feb 21, 2017 at 6:01 AM, Gao Kai <gaok12@...> wrote:
Hi Anil,

Thanks for the notice. We'll look into that.

Regards,
Kai


> -----原始邮件-----
> 发件人: "Anil Belur" <abelur@...>
> 发送时间: 2017-02-20 09:49:48 (星期一)
> 收件人: "release@...g" <release@...g>, alto-dev@...g
> 抄送:
> 主题: [alto-dev] [release] autorelease carbon build failing on alto tests
>
> Hello,
>
> Carbon autorelease build is failing on tests. Please refer logs in [1.].
>
> [1.]
> https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/167/
>
> Thanks,
> Anil
>
>
> 01:57:36 [INFO] features-alto-release ..............................
> FAILURE [07:27 min]
> ...
> 01:57:36 Tests in error:
> 01:57:36   Can't install feature odl-alto-auto-maps/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [361]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-basic/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-core/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-manual-maps/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-northbound/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-release/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-simpleecs/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [369]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-simpleird/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature
> odl-alto-standard-northbound-route/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [352]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36

_______________________________________________
release mailing list
release@...
https://lists.opendaylight.org/mailman/listinfo/release



Jensen Zhang
 

@Kai, I think we are facing the same issue as aaa was. See this mail [0].

This patch [1] should work. I passed the SingleFeatureTest in my local machine.

On Mon, Feb 27, 2017 at 3:41 PM, Jensen Zhang <jingxuan.n.zhang@...> wrote:
Hi Thanh,

Sorry about that. We are working on this issue.

Thanks,
Jensen

On Feb 27, 2017 11:43 AM, "Thanh Ha" <thanh.ha@...> wrote:
Hi Kai,

Is there an ETA one when the tests can be fixed?

Ideally we'd like the tests fixed rather than disabled. If we cannot get this resolved soon we will need to remove Alto from the Autorelease build as it's blocking us from building the Carbon release.

Thanks,
Thanh


On Sun, Feb 26, 2017 at 10:27 PM, Anil Belur <abelur@...> wrote:
Hi, 

Autorelease carbon has been failing for on the same issue more than a week. 
Can you please resolve the issue by disabling the tests or we will have to remove alto project from autolrease until the issue gets resolved. 
Please resolve the issue latest by tomorrow, since we want autorelease build not to be blocked.

Thanks,
Anil

On Tue, Feb 21, 2017 at 6:01 AM, Gao Kai <gaok12@...> wrote:
Hi Anil,

Thanks for the notice. We'll look into that.

Regards,
Kai


> -----原始邮件-----
> 发件人: "Anil Belur" <abelur@...>
> 发送时间: 2017-02-20 09:49:48 (星期一)
> 收件人: "release@...g" <release@...g>, alto-dev@...g
> 抄送:
> 主题: [alto-dev] [release] autorelease carbon build failing on alto tests
>
> Hello,
>
> Carbon autorelease build is failing on tests. Please refer logs in [1.].
>
> [1.]
> https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/167/
>
> Thanks,
> Anil
>
>
> 01:57:36 [INFO] features-alto-release ..............................
> FAILURE [07:27 min]
> ...
> 01:57:36 Tests in error:
> 01:57:36   Can't install feature odl-alto-auto-maps/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [361]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-basic/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-core/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-manual-maps/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-northbound/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-release/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-simpleecs/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [369]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-simpleird/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature
> odl-alto-standard-northbound-route/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [352]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36

_______________________________________________
release mailing list
release@...
https://lists.opendaylight.org/mailman/listinfo/release




Gao Kai
 

Hi Thanh,

Jensen has submitted a patch to resolve the issue. Can you or Anil please confirm if it is still blocking the release?

Regards,
Kai

On 27/02/17 06:01, Jensen Zhang wrote:
@Kai, I think we are facing the same issue as aaa was. See this mail [0].

This patch [1] should work. I passed the SingleFeatureTest in my local machine.


On Mon, Feb 27, 2017 at 3:41 PM, Jensen Zhang <jingxuan.n.zhang@...> wrote:
Hi Thanh,

Sorry about that. We are working on this issue.

Thanks,
Jensen

On Feb 27, 2017 11:43 AM, "Thanh Ha" <thanh.ha@...> wrote:
Hi Kai,

Is there an ETA one when the tests can be fixed?

Ideally we'd like the tests fixed rather than disabled. If we cannot get this resolved soon we will need to remove Alto from the Autorelease build as it's blocking us from building the Carbon release.

Thanks,
Thanh


On Sun, Feb 26, 2017 at 10:27 PM, Anil Belur <abelur@...> wrote:
Hi, 

Autorelease carbon has been failing for on the same issue more than a week. 
Can you please resolve the issue by disabling the tests or we will have to remove alto project from autolrease until the issue gets resolved. 
Please resolve the issue latest by tomorrow, since we want autorelease build not to be blocked.

Thanks,
Anil

On Tue, Feb 21, 2017 at 6:01 AM, Gao Kai <gaok12@...> wrote:
Hi Anil,

Thanks for the notice. We'll look into that.

Regards,
Kai


> -----原始邮件-----
> 发件人: "Anil Belur" <abelur@...>
> 发送时间: 2017-02-20 09:49:48 (星期一)
> 收件人: "release@...g" <release@...g>, alto-dev@...g
> 抄送:
> 主题: [alto-dev] [release] autorelease carbon build failing on alto tests
>
> Hello,
>
> Carbon autorelease build is failing on tests. Please refer logs in [1.].
>
> [1.]
> https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/167/
>
> Thanks,
> Anil
>
>
> 01:57:36 [INFO] features-alto-release ..............................
> FAILURE [07:27 min]
> ...
> 01:57:36 Tests in error:
> 01:57:36   Can't install feature odl-alto-auto-maps/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [361]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-basic/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-core/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-manual-maps/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-northbound/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-release/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [346]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-simpleecs/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [369]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature odl-alto-simpleird/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [338]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36   Can't install feature
> odl-alto-standard-northbound-route/0.4.0-Carbon:
> 01:57:36 Could not start bundle
> mvn:org.opendaylight.alto.core/alto-northbound-impl/0.4.0-Carbon in
> feature(s) odl-alto-northbound-0.4.0-Carbon: The bundle
> "org.opendaylight.alto.core.alto-northbound-impl_0.4.0.Carbon [352]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.eclipse.jetty.servlets; version="[9.2.0,10.0.0)"
> 01:57:36

_______________________________________________
release mailing list
release@...
https://lists.opendaylight.org/mailman/listinfo/release





_______________________________________________
alto-dev mailing list
alto-dev@...
https://lists.opendaylight.org/mailman/listinfo/alto-dev


Robert Varga <nite@...>
 

On 02/27/2017 02:47 PM, Gao Kai wrote:
Hi Thanh,

Jensen has submitted a patch to resolve the issue. Can you or Anil
please confirm if it is still blocking the release?
The patch is not merged, can you hit the 'Submit' button, please?

Thanks,
Robert


Gao Kai <gaok12@...>
 

Hi Robert,

Just noticed that. Thanks for the reminder.

Regards,
Kai

在2017-02-27 22:22:35,Gao Kai<gaok12@...>写道:



On 02/27/2017 02:47 PM, Gao Kai wrote:
Hi Thanh,

Jensen has submitted a patch to resolve the issue. Can you or Anil
please confirm if it is still blocking the release?
The patch is not merged, can you hit the 'Submit' button, please?

Thanks,
Robert


Thanh Ha <thanh.ha@...>
 

Thanks Kai, Jensen,

I queued up a new autorelease carbon build [0], we'll find out if it unblocks us in a few hours.

Regards,
Thanh

On Mon, Feb 27, 2017 at 10:03 AM, Gao Kai <gaok12@...> wrote:
Hi Robert,

Just noticed that. Thanks for the reminder.

Regards,
Kai

在2017-02-27 22:22:35,Gao Kai<gaok12@....cn>写道:
>
>
> On 02/27/2017 02:47 PM, Gao Kai wrote:
> > Hi Thanh,
> >
> > Jensen has submitted a patch to resolve the issue. Can you or Anil
> > please confirm if it is still blocking the release?
>
> The patch is not merged, can you hit the 'Submit' button, please?
>
> Thanks,
> Robert


Gao Kai <gaok12@...>
 

Thanks Thanh,

I'll follow up the auto release and see if things work out.

Regards,
Kai

在2017-02-27 23:20:59,Gao Kaigaok12@...写道:

Thanks Kai, Jensen,

I queued up a new autorelease carbon build [0], we'll find out if it unblocks us in a few hours.

Regards,
Thanh

[0] https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/180/


On Mon, Feb 27, 2017 at 10:03 AM, Gao Kai <gaok12@...> wrote:
Hi Robert,

Just noticed that. Thanks for the reminder.

Regards,
Kai

在2017-02-27 22:22:35,Gao Kai<gaok12@....cn>写道:
>
>
> On 02/27/2017 02:47 PM, Gao Kai wrote:
> > Hi Thanh,
> >
> > Jensen has submitted a patch to resolve the issue. Can you or Anil
> > please confirm if it is still blocking the release?
>
> The patch is not merged, can you hit the 'Submit' button, please?
>
> Thanks,
> Robert




Anil Belur <abelur@...>
 

Thanks Kai, Jensen for fixing this issue. 

On Tue, Feb 28, 2017 at 1:35 AM, Gao Kai <gaok12@...> wrote:
Thanks Thanh,

I'll follow up the auto release and see if things work out.

Regards,
Kai

在2017-02-27 23:20:59,Gao Kaigaok12@....cn写道:

Thanks Kai, Jensen,

I queued up a new autorelease carbon build [0], we'll find out if it unblocks us in a few hours.

Regards,
Thanh

[0] https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/180/


On Mon, Feb 27, 2017 at 10:03 AM, Gao Kai <gaok12@...> wrote:
Hi Robert,

Just noticed that. Thanks for the reminder.

Regards,
Kai

在2017-02-27 22:22:35,Gao Kai<gaok12@....cn>写道:
>
>
> On 02/27/2017 02:47 PM, Gao Kai wrote:
> > Hi Thanh,
> >
> > Jensen has submitted a patch to resolve the issue. Can you or Anil
> > please confirm if it is still blocking the release?
>
> The patch is not merged, can you hit the 'Submit' button, please?
>
> Thanks,
> Robert




_______________________________________________
release mailing list
release@...
https://lists.opendaylight.org/mailman/listinfo/release