ODL Nitrogen | PCEP is not up


Durai Raj Kumar
 

Hi All, 
I am trying to Establish a PCEP session and push SR-TE to vMXs from ODL running Nitrogen relesae
PCEP topology is configured on Routers. From the documentation, I understand "This capability is enabled by default. No additional configuration is required."   I believe all necessary features are installed/started but the PCEP session is not established yet
+++++++++++++++++++++++++++++++++++++++++++++
opendaylight-user@root>feature:list | grep odl-bgpcep-pcep
odl-bgpcep-pcep-stateful07                       | 0.8.3            |          | Started     | odl-bgpcep-pcep-stateful07                       | OpenDaylight :: PCEP :: Stateful 07
odl-bgpcep-pcep-dependencies                     | 0.8.3            |          | Started     | odl-bgpcep-pcep-dependencies                     | OpenDaylight :: PCEP :: Dependencies
odl-bgpcep-pcep-topology-provider                | 0.8.3            |          | Started     | odl-bgpcep-0.8.3                                 | OpenDaylight :: PCEP :: Topology Provider
odl-bgpcep-pcep-tunnel-provider                  | 0.8.3            |          | Started     | odl-bgpcep-pcep-tunnel-provider                  | OpenDaylight :: PCEP :: Tunnel Provider
odl-bgpcep-pcep                                  | 0.8.3            | x        | Started     | odl-bgpcep-pcep                                  | OpenDaylight :: PCEP
odl-bgpcep-pcep-api                              | 0.8.3            |          | Started     | odl-bgpcep-0.8.3                                 | OpenDaylight :: PCEP :: Api
odl-bgpcep-pcep-topology                         | 0.8.3            |          | Started     | odl-bgpcep-pcep-topology                         | OpenDaylight :: PCEP :: Topology
odl-bgpcep-pcep-auto-bandwidth                   | 0.8.3            |          | Started     | odl-bgpcep-pcep-auto-bandwidth                   | OpenDaylight :: PCEP :: Auto Bandwidth
odl-bgpcep-pcep-impl                             | 0.8.3            |          | Started     | odl-bgpcep-pcep-impl                             | OpenDaylight :: PCEP :: Impl
odl-bgpcep-pcep-segment-routing                  | 0.8.3            |          | Started     | odl-bgpcep-pcep-segment-routing                  | OpenDaylight :: PCEP :: Segment Routing
opendaylight-user@root>feature:list | grep odl-restconf
odl-restconf                                     | 1.6.3            | x        | Started     | odl-restconf                                     | OpenDaylight :: Restconf
odl-restconf-all                                 | 1.6.3            | x        | Started     | odl-restconf-all                                 | OpenDaylight :: Restconf :: All
odl-restconf-noauth                              | 1.6.3            |          | Started     | odl-controller-1.6.3                             | OpenDaylight :: Restconf
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

When I get the below URL, the output is 

+++++++++++++++++++++++++++++++
    "errors": {
        "error": [
            {
                "error-type": "application",
                "error-tag": "data-missing",
                "error-message": "Request could not be completed because the relevant data model content does not exist "
++++++++++++++++++++++++++++++


Similarly, when I tried to configure segment routing, received the below Error thought segment routing app is already installed.

"error-message": "URI has bad format. Possible reasons:\n 1. \"pcep-segment-routing-app-config:pcep-segment-routing-app-config\" was not found in parent data node.\n 2. \"pcep-segment-routing-app-config:pcep-segment-routing-app-config\" is behind mount point. Then it should be in format \"/yang-ext:mount/pcep-segment-routing-app-config:pcep-segment-routing-app-config\".

Could someone help me to understand what am I missing? 

Redirect to right mail/support group if this is not

Thank you in advance 

Regards
Durai 

Regards
Durai 
 


Durai Raj Kumar
 

Does the mail list is active? 

Any response is appreciated!

Thank you in advance

Regards
Durai 

On Thu, Jul 4, 2019 at 8:11 AM Durai Raj Kumar PV <route2rajkumar@...> wrote:
Hi All, 
I am trying to Establish a PCEP session and push SR-TE to vMXs from ODL running Nitrogen relesae
PCEP topology is configured on Routers. From the documentation, I understand "This capability is enabled by default. No additional configuration is required."   I believe all necessary features are installed/started but the PCEP session is not established yet
+++++++++++++++++++++++++++++++++++++++++++++
opendaylight-user@root>feature:list | grep odl-bgpcep-pcep
odl-bgpcep-pcep-stateful07                       | 0.8.3            |          | Started     | odl-bgpcep-pcep-stateful07                       | OpenDaylight :: PCEP :: Stateful 07
odl-bgpcep-pcep-dependencies                     | 0.8.3            |          | Started     | odl-bgpcep-pcep-dependencies                     | OpenDaylight :: PCEP :: Dependencies
odl-bgpcep-pcep-topology-provider                | 0.8.3            |          | Started     | odl-bgpcep-0.8.3                                 | OpenDaylight :: PCEP :: Topology Provider
odl-bgpcep-pcep-tunnel-provider                  | 0.8.3            |          | Started     | odl-bgpcep-pcep-tunnel-provider                  | OpenDaylight :: PCEP :: Tunnel Provider
odl-bgpcep-pcep                                  | 0.8.3            | x        | Started     | odl-bgpcep-pcep                                  | OpenDaylight :: PCEP
odl-bgpcep-pcep-api                              | 0.8.3            |          | Started     | odl-bgpcep-0.8.3                                 | OpenDaylight :: PCEP :: Api
odl-bgpcep-pcep-topology                         | 0.8.3            |          | Started     | odl-bgpcep-pcep-topology                         | OpenDaylight :: PCEP :: Topology
odl-bgpcep-pcep-auto-bandwidth                   | 0.8.3            |          | Started     | odl-bgpcep-pcep-auto-bandwidth                   | OpenDaylight :: PCEP :: Auto Bandwidth
odl-bgpcep-pcep-impl                             | 0.8.3            |          | Started     | odl-bgpcep-pcep-impl                             | OpenDaylight :: PCEP :: Impl
odl-bgpcep-pcep-segment-routing                  | 0.8.3            |          | Started     | odl-bgpcep-pcep-segment-routing                  | OpenDaylight :: PCEP :: Segment Routing
opendaylight-user@root>feature:list | grep odl-restconf
odl-restconf                                     | 1.6.3            | x        | Started     | odl-restconf                                     | OpenDaylight :: Restconf
odl-restconf-all                                 | 1.6.3            | x        | Started     | odl-restconf-all                                 | OpenDaylight :: Restconf :: All
odl-restconf-noauth                              | 1.6.3            |          | Started     | odl-controller-1.6.3                             | OpenDaylight :: Restconf
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

When I get the below URL, the output is 

+++++++++++++++++++++++++++++++
    "errors": {
        "error": [
            {
                "error-type": "application",
                "error-tag": "data-missing",
                "error-message": "Request could not be completed because the relevant data model content does not exist "
++++++++++++++++++++++++++++++


Similarly, when I tried to configure segment routing, received the below Error thought segment routing app is already installed.

"error-message": "URI has bad format. Possible reasons:\n 1. \"pcep-segment-routing-app-config:pcep-segment-routing-app-config\" was not found in parent data node.\n 2. \"pcep-segment-routing-app-config:pcep-segment-routing-app-config\" is behind mount point. Then it should be in format \"/yang-ext:mount/pcep-segment-routing-app-config:pcep-segment-routing-app-config\".

Could someone help me to understand what am I missing? 

Redirect to right mail/support group if this is not

Thank you in advance 

Regards
Durai 

Regards
Durai 
 


adam
 

What does the log says on both the router and odl (tail -f karaf-distro/data/log/karaf.log)

 

I only tried PCEP to control RSVP-TE (but at least got the session up)

 

From my notes:

OpenDaylight is pre-configured with baseline PCEP configuration. The default shipped configuration will start a PCE server on port 4189.

32-pcep.xml - basic PCEP configuration, including session parameters 39-pcep-provider.xml - configuration for PCEP provider

 

nano ./etc/opendaylight/karaf/39-pcep-provider.xml

uncomment and add client 10.0.0.3

<SNIP>

                    <client>

                        <address>10.0.0.3</address>

                    </client>

<SNIP>

 

 

These are the settings that worked for me (well at least to get the PCEP session up) -getting the LSPs programmed is a whole another level though…

set protocols pcep pce ODL local-address 10.0.0.3

set protocols pcep pce ODL destination-ipv4-address 192.0.2.2

set protocols pcep pce ODL destination-port 4189

set protocols pcep pce ODL pce-type active

set protocols pcep pce ODL pce-type stateful

set protocols pcep pce ODL lsp-provisioning

set protocols pcep pce ODL p2mp-lsp-report-capability

set protocols pcep pce ODL lsp-retry-delegation

 

admin@pe1> show path-computation-client status

 

Session              Type                        Provisioning   Status

  ODL                Stateful Active             On             Up          

 

LSP Summary

  Total number of LSPs        : 22      

  Static LSPs                 : 22      

  Externally controlled LSPs  : 0       

  Externally provisioned LSPs : 0/16000 (current/limit)

  Orphaned LSPs               : 0       

 

ODL (main)

  Delegated              : 0              

  Externally provisioned : 0              

 

admin@pe1> show path-computation-client statistics

 

PCE ODL

--------------------------------------------

General

    PCE IP address           : 192.0.2.2

    Local IP address         : 10.0.0.3

    Priority                 : 0

    PCE status               : PCE_STATE_UP

    Session type             : PCE_TYPE_STATEFULACTIVE

    LSP provisioning allowed : On

    P2MP LSP report allowed  : Off

    P2MP LSP update allowed  : Off

    P2MP LSP init allowed    : Off

    PCE-mastership           : main

 

Counters

    PCReqs              Total: 0            last 5min: 0            last hour: 0       

    PCReps              Total: 0            last 5min: 0            last hour: 0       

    PCRpts              Total: 12           last 5min: 4            last hour: 12      

    PCUpdates           Total: 0            last 5min: 0            last hour: 0       

    PCCreates           Total: 0            last 5min: 0            last hour: 0       

 

Timers

    Local  Keepalive timer:   30 [s]  Dead timer:  120 [s]  LSP cleanup timer:    0 [s]

    Remote Keepalive timer:   30 [s]  Dead timer:  120 [s]  LSP cleanup timer:    0 [s]

 

Errors

    PCErr-recv

    PCErr-sent

    PCE-PCC-NTFS

    PCC-PCE-NTFS

adam

 

From: bgpcep-users-bounces@... <bgpcep-users-bounces@...> On Behalf Of Durai Raj Kumar PV
Sent: Friday, July 5, 2019 7:02 AM
To: bgpcep-users@...
Subject: Re: [bgpcep-users] ODL Nitrogen | PCEP is not up

 

Does the mail list is active? 

 

Any response is appreciated!

 

Thank you in advance

 

Regards

Durai 

 

On Thu, Jul 4, 2019 at 8:11 AM Durai Raj Kumar PV <route2rajkumar@...> wrote:

Hi All, 

I am trying to Establish a PCEP session and push SR-TE to vMXs from ODL running Nitrogen relesae

PCEP topology is configured on Routers. From the documentation, I understand "This capability is enabled by default. No additional configuration is required."   I believe all necessary features are installed/started but the PCEP session is not established yet

+++++++++++++++++++++++++++++++++++++++++++++
opendaylight-user@root>feature:list | grep odl-bgpcep-pcep
odl-bgpcep-pcep-stateful07                       | 0.8.3            |          | Started     | odl-bgpcep-pcep-stateful07                       | OpenDaylight :: PCEP :: Stateful 07
odl-bgpcep-pcep-dependencies                     | 0.8.3            |          | Started     | odl-bgpcep-pcep-dependencies                     | OpenDaylight :: PCEP :: Dependencies
odl-bgpcep-pcep-topology-provider                | 0.8.3            |          | Started     | odl-bgpcep-0.8.3                                 | OpenDaylight :: PCEP :: Topology Provider
odl-bgpcep-pcep-tunnel-provider                  | 0.8.3            |          | Started     | odl-bgpcep-pcep-tunnel-provider                  | OpenDaylight :: PCEP :: Tunnel Provider
odl-bgpcep-pcep                                  | 0.8.3            | x        | Started     | odl-bgpcep-pcep                                  | OpenDaylight :: PCEP
odl-bgpcep-pcep-api                              | 0.8.3            |          | Started     | odl-bgpcep-0.8.3                                 | OpenDaylight :: PCEP :: Api
odl-bgpcep-pcep-topology                         | 0.8.3            |          | Started     | odl-bgpcep-pcep-topology                         | OpenDaylight :: PCEP :: Topology
odl-bgpcep-pcep-auto-bandwidth                   | 0.8.3            |          | Started     | odl-bgpcep-pcep-auto-bandwidth                   | OpenDaylight :: PCEP :: Auto Bandwidth
odl-bgpcep-pcep-impl                             | 0.8.3            |          | Started     | odl-bgpcep-pcep-impl                             | OpenDaylight :: PCEP :: Impl
odl-bgpcep-pcep-segment-routing                  | 0.8.3            |          | Started     | odl-bgpcep-pcep-segment-routing                  | OpenDaylight :: PCEP :: Segment Routing
opendaylight-user@root>feature:list | grep odl-restconf
odl-restconf                                     | 1.6.3            | x        | Started     | odl-restconf                                     | OpenDaylight :: Restconf
odl-restconf-all                                 | 1.6.3            | x        | Started     | odl-restconf-all                                 | OpenDaylight :: Restconf :: All
odl-restconf-noauth                              | 1.6.3            |          | Started     | odl-controller-1.6.3                             | OpenDaylight :: Restconf
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

When I get the below URL, the output is 

 

+++++++++++++++++++++++++++++++
    "errors": {
        "error": [
            {
                "error-type": "application",
                "error-tag": "data-missing",
                "error-message": "Request could not be completed because the relevant data model content does not exist "
++++++++++++++++++++++++++++++

 

 

Similarly, when I tried to configure segment routing, received the below Error thought segment routing app is already installed.

 

"error-message": "URI has bad format. Possible reasons:\n 1. \"pcep-segment-routing-app-config:pcep-segment-routing-app-config\" was not found in parent data node.\n 2. \"pcep-segment-routing-app-config:pcep-segment-routing-app-config\" is behind mount point. Then it should be in format \"/yang-ext:mount/pcep-segment-routing-app-config:pcep-segment-routing-app-config\".

 

Could someone help me to understand what am I missing? 

 

Redirect to right mail/support group if this is not

 

Thank you in advance 

 

Regards

Durai 

 

Regards

Durai 

 


Durai Raj Kumar
 

Hi Adam, 

Thank you for your reply. 

The Router side configurations are simple and straightforward. 

I see some issue/misconfigured on ODL side where I get the below error when checked in karaf logs 

2019-07-03 19:45:16,207 | INFO  | config-pusher    | ConfigPusherImpl                 | 191 - org.opendaylight.controller.config-persister-impl - 0.7.3 | Successfully pushed configuration snapshot 30-programming.xml(odl-bgpcep-pcep,odl-bgpcep-pcep)
2019-07-03 19:45:16,207 | INFO  | config-pusher    | ConfigPusherImpl                 | 191 - org.opendaylight.controller.config-persister-impl - 0.7.3 | Pushing configuration snapshot 39-pcep-provider.xml(odl-bgpcep-pcep,odl-bgpcep-pcep)
2019-07-03 19:45:16,284 | ERROR | config-pusher    | ConfigPusherImpl                 | 191 - org.opendaylight.controller.config-persister-impl - 0.7.3 | Failed to apply configuration snapshot: 39-pcep-provider.xml(odl-bgpcep-pcep,odl-bgpcep-pcep). Config snapshot is not semantically correct and will be IGNORED. for detailed information see enclosed exception.
org.opendaylight.controller.config.persist.impl.ConfigPusherImpl$ConfigSnapshotFailureException: Failed to apply config snapshot: 39-pcep-provider.xml(odl-bgpcep-pcep,odl-bgpcep-pcep) during phase: edit

I am attaching the 39-pcep-provider.xml and log file for your reference 

Do you use NItrogen release? 

Thanks again 

Regards
Durai 


On Fri, Jul 5, 2019 at 3:36 PM <adamv0025@...> wrote:

What does the log says on both the router and odl (tail -f karaf-distro/data/log/karaf.log)

 

I only tried PCEP to control RSVP-TE (but at least got the session up)

 

From my notes:

OpenDaylight is pre-configured with baseline PCEP configuration. The default shipped configuration will start a PCE server on port 4189.

32-pcep.xml - basic PCEP configuration, including session parameters 39-pcep-provider.xml - configuration for PCEP provider

 

nano ./etc/opendaylight/karaf/39-pcep-provider.xml

uncomment and add client 10.0.0.3

<SNIP>

                    <client>

                        <address>10.0.0.3</address>

                    </client>

<SNIP>

 

 

These are the settings that worked for me (well at least to get the PCEP session up) -getting the LSPs programmed is a whole another level though…

set protocols pcep pce ODL local-address 10.0.0.3

set protocols pcep pce ODL destination-ipv4-address 192.0.2.2

set protocols pcep pce ODL destination-port 4189

set protocols pcep pce ODL pce-type active

set protocols pcep pce ODL pce-type stateful

set protocols pcep pce ODL lsp-provisioning

set protocols pcep pce ODL p2mp-lsp-report-capability

set protocols pcep pce ODL lsp-retry-delegation

 

admin@pe1> show path-computation-client status

 

Session              Type                        Provisioning   Status

  ODL                Stateful Active             On             Up          

 

LSP Summary

  Total number of LSPs        : 22      

  Static LSPs                 : 22      

  Externally controlled LSPs  : 0       

  Externally provisioned LSPs : 0/16000 (current/limit)

  Orphaned LSPs               : 0       

 

ODL (main)

  Delegated              : 0              

  Externally provisioned : 0              

 

admin@pe1> show path-computation-client statistics

 

PCE ODL

--------------------------------------------

General

    PCE IP address           : 192.0.2.2

    Local IP address         : 10.0.0.3

    Priority                 : 0

    PCE status               : PCE_STATE_UP

    Session type             : PCE_TYPE_STATEFULACTIVE

    LSP provisioning allowed : On

    P2MP LSP report allowed  : Off

    P2MP LSP update allowed  : Off

    P2MP LSP init allowed    : Off

    PCE-mastership           : main

 

Counters

    PCReqs              Total: 0            last 5min: 0            last hour: 0       

    PCReps              Total: 0            last 5min: 0            last hour: 0       

    PCRpts              Total: 12           last 5min: 4            last hour: 12      

    PCUpdates           Total: 0            last 5min: 0            last hour: 0       

    PCCreates           Total: 0            last 5min: 0            last hour: 0       

 

Timers

    Local  Keepalive timer:   30 [s]  Dead timer:  120 [s]  LSP cleanup timer:    0 [s]

    Remote Keepalive timer:   30 [s]  Dead timer:  120 [s]  LSP cleanup timer:    0 [s]

 

Errors

    PCErr-recv

    PCErr-sent

    PCE-PCC-NTFS

    PCC-PCE-NTFS

adam

 

From: bgpcep-users-bounces@... <bgpcep-users-bounces@...> On Behalf Of Durai Raj Kumar PV
Sent: Friday, July 5, 2019 7:02 AM
To: bgpcep-users@...
Subject: Re: [bgpcep-users] ODL Nitrogen | PCEP is not up

 

Does the mail list is active? 

 

Any response is appreciated!

 

Thank you in advance

 

Regards

Durai 

 

On Thu, Jul 4, 2019 at 8:11 AM Durai Raj Kumar PV <route2rajkumar@...> wrote:

Hi All, 

I am trying to Establish a PCEP session and push SR-TE to vMXs from ODL running Nitrogen relesae

PCEP topology is configured on Routers. From the documentation, I understand "This capability is enabled by default. No additional configuration is required."   I believe all necessary features are installed/started but the PCEP session is not established yet

+++++++++++++++++++++++++++++++++++++++++++++
opendaylight-user@root>feature:list | grep odl-bgpcep-pcep
odl-bgpcep-pcep-stateful07                       | 0.8.3            |          | Started     | odl-bgpcep-pcep-stateful07                       | OpenDaylight :: PCEP :: Stateful 07
odl-bgpcep-pcep-dependencies                     | 0.8.3            |          | Started     | odl-bgpcep-pcep-dependencies                     | OpenDaylight :: PCEP :: Dependencies
odl-bgpcep-pcep-topology-provider                | 0.8.3            |          | Started     | odl-bgpcep-0.8.3                                 | OpenDaylight :: PCEP :: Topology Provider
odl-bgpcep-pcep-tunnel-provider                  | 0.8.3            |          | Started     | odl-bgpcep-pcep-tunnel-provider                  | OpenDaylight :: PCEP :: Tunnel Provider
odl-bgpcep-pcep                                  | 0.8.3            | x        | Started     | odl-bgpcep-pcep                                  | OpenDaylight :: PCEP
odl-bgpcep-pcep-api                              | 0.8.3            |          | Started     | odl-bgpcep-0.8.3                                 | OpenDaylight :: PCEP :: Api
odl-bgpcep-pcep-topology                         | 0.8.3            |          | Started     | odl-bgpcep-pcep-topology                         | OpenDaylight :: PCEP :: Topology
odl-bgpcep-pcep-auto-bandwidth                   | 0.8.3            |          | Started     | odl-bgpcep-pcep-auto-bandwidth                   | OpenDaylight :: PCEP :: Auto Bandwidth
odl-bgpcep-pcep-impl                             | 0.8.3            |          | Started     | odl-bgpcep-pcep-impl                             | OpenDaylight :: PCEP :: Impl
odl-bgpcep-pcep-segment-routing                  | 0.8.3            |          | Started     | odl-bgpcep-pcep-segment-routing                  | OpenDaylight :: PCEP :: Segment Routing
opendaylight-user@root>feature:list | grep odl-restconf
odl-restconf                                     | 1.6.3            | x        | Started     | odl-restconf                                     | OpenDaylight :: Restconf
odl-restconf-all                                 | 1.6.3            | x        | Started     | odl-restconf-all                                 | OpenDaylight :: Restconf :: All
odl-restconf-noauth                              | 1.6.3            |          | Started     | odl-controller-1.6.3                             | OpenDaylight :: Restconf
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

When I get the below URL, the output is 

 

+++++++++++++++++++++++++++++++
    "errors": {
        "error": [
            {
                "error-type": "application",
                "error-tag": "data-missing",
                "error-message": "Request could not be completed because the relevant data model content does not exist "
++++++++++++++++++++++++++++++

 

 

Similarly, when I tried to configure segment routing, received the below Error thought segment routing app is already installed.

 

"error-message": "URI has bad format. Possible reasons:\n 1. \"pcep-segment-routing-app-config:pcep-segment-routing-app-config\" was not found in parent data node.\n 2. \"pcep-segment-routing-app-config:pcep-segment-routing-app-config\" is behind mount point. Then it should be in format \"/yang-ext:mount/pcep-segment-routing-app-config:pcep-segment-routing-app-config\".

 

Could someone help me to understand what am I missing? 

 

Redirect to right mail/support group if this is not

 

Thank you in advance 

 

Regards

Durai 

 

Regards

Durai