Dlux Yang UI

Kirill Varlamov <k.varlamov@...>

Hi Team!
Running ODL I always face the same problem - Dlux Yang UI doesn't render Yang data and shows no models available. It always hangs with "Loading modules from controller - Processing modules" alert in bottom of the page with constantly rotating spin symbol and never finish. I tried different features combination, but guides and ODL summit materials say that just odl-dlux-all should be enough to see YANG tree. It's installed.
Not sure this related or not, but in browser debug I see yangutils.services.js JS-script tries to GET several .yang.xml files from <dlux_url>/yang2xml/ and gets Error 404. Notable that my karaf distribution doesn't have files with such extension at all.
I tried different stable ODL images published on site (downloaded as zip archives):
0.2.4 Helium
0.3.3 Lithium
Today I tried just-released Beryllium 0.4.0 with exactly the same result.
I tried to run it on different machines with Ubuntu 14.04 LTS and used Chromium and Firefox as browsers.
Do you have any idea what could be the root cause for such problem? Thanks and kindly appreciate for your help.