Re: [defense4all-dev] Upgrading Jackson library to 2.3.0


Konstantin Pozdeev <KonstantinP@...>
 

Madhu
Defense4all is ready to work with the new library.
It's not exactly same as you proposed in the code change, but based on.
We will use new library to communicate with controller and previous library for our internal REST server.
This change is ready to be merged today.
Regards.

-----Original Message-----
From: defense4all-dev-bounces@... [mailto:defense4all-dev-bounces@...] On Behalf Of Madhu Venguopal
Sent: Saturday, January 04, 2014 7:42 PM
To: dev; ovsdb-dev@...; lispflowmapping-dev@...; <affinity-dev@...>; defense4all-dev@...; vtn-dev@...; snmp4sdn-dev@...; Alissa Bonas; discuss@...; 'integration-dev@...'
Subject: Re: [defense4all-dev] Upgrading Jackson library to 2.3.0


Coding and testing is complete on most of the projects. But we are facing build/IT problems with a few projects such as VTN & defense4all due to the build environment itself (which are not due to this jackson upgrade).

Also, there is a chicken-and-egg problem with respect to the build environment we currently have and hence we have to merge the changes on the Controller in order to proceed to the next steps.

https://git.opendaylight.org/gerrit/#/c/3905/ was reviewed earlier and I was holding off merging it to make sure we have enough confidence with other projects and we have it now.

I will be merging https://git.opendaylight.org/gerrit/#/c/3905/ today and there will be temporary northbound related build/run-time/IT issues in other projects until the changes that are currently in review are merged.
Please help review and merge them in your respective projects.

Thanks,
Madhu

On 12/30/13, 10:27 AM, Madhu Venguopal wrote:
Hi Devs,

We are upgrading the jackson library from the old 1.9.8 to the newer
2.3.0 in the controller project.
https://git.opendaylight.org/gerrit/#/c/3905/
The NB Integration tests passed in the controller project.
This upgrade is required to bring in third-party library consistency
across the projects as discussed in the TSC call.

The changes are pretty much transparent unless some of the Jackson's
json annotations are used.
I noticed that few of the projects outside the controller uses these
annotations and depends on the Controller's Northbound layer. Hence
these projects must also upgrade from 1.9.8 to 2.3.0.

Alissa & I will take care of these upgrades as well. This is a heads
up to all the devs in the relevant projects to expect code-review
requests from us.

Please let us know if you have any questions/concerns.

Thanks,
Madhu
_______________________________________________
defense4all-dev mailing list
defense4all-dev@...
https://lists.opendaylight.org/mailman/listinfo/defense4all-dev

Join z.archive.ovsdb-dev@lists.opendaylight.org to automatically receive all group messages.